Results 1 to 10 of 10
  1. #1
    Member FLV8Jeeper's Avatar
    Join Date
    Apr 2010
    Location
    Near Tampa,FL
    Posts
    69
    Rep Power
    92

    ZJ What kind of Cooling Fan & Radiator are you running?

    I just wanted to get some input on what you all are running as far as Cooling Fan and Radiator. I have a 5.9L with a mild cam,heads,roller rockers,headers, SCT tuned. I'm currently running a 180 degree Thermostat a 2 core Aluminum Radiator I got of E-Bay and a Lincoln Mark VIII Electric fan using the wiring harness I got off E-Bay. I'm having problems with blowing the 50 amp fuse in the electric fan wiring harness. It has blown and also melted the fuse holder. I sent the harness back to the company and they replaced it with a new fuse holder and said they have never had that happen before. Well same thing happened yesturday on my way home, blew the fuse and melted the fuse holder. I belive there is something gone wrong inside the elect. fan motor causing the fuse to blow and melt the fuse holder. I'm getting real sick of having this problem and going to switch back to the factory fan clutch and fan shroud. My engine runs 20 to 25 degrees hotter with the factory fan clutch set up, thats the only downfall. At 75mph engine runs 220 - 225 and with A/C on it runs 230 and on some very hot days I have to turn the A/C off to get the engine temp down to 220 - 225.

    Running the Mark VIII elect. fan engine runs 180 - 200 and 210 with the A/C on.

    Let me know what you all think about my set up and what you all are running and the temp your engine runs.

    THANKS
    1998 ZJ TSI " 5.9 Limited Clone" New 5.9L, Hughes Engines Iron Ram Heads,Comp Cam, HS Roller Rockers, SCT Tuned, Doug Thorley Headers, 231HD,ARB Lockers F&R, D-30, Ford 8.8, 4.56 Gears, Custom Homebuilt Steering,Bumpers,Rock Rails, Homebuilt FRT. Long Arms, Clayton Rear Long Arms, 6.5" Lift, 33x12.50x15 BFG KM 2 M/T

  2. #2
    Modfag Saleen4971's Avatar
    Join Date
    Jan 2009
    Location
    Indianapolis, IN
    Posts
    7,358
    Rep Power
    2340
    sounds like the fan is going bad. when an electric motor is stalled and trying to move, it draws a ton of current.
    Ross
    1998 Grand Cherokee 5.9 Limited
    MPP Headers - Thunderbolt Metallic Cat - 3" Mag catback - EBC Brakes w/ drilled Rotors - 4bbl M1 - Vortech 12psi - Built trans & 2900 stall - Ford 8.8 - Addco & Hellwig Sways - Poly Bushings - H&R Springs - Grabber UHP Tires - Alpine/Infinity Stereo - FX-R BiXenon Retrofit

  3. #3
    Forum CONDUCTOR Man Z88Z's Avatar
    Join Date
    Jan 2009
    Location
    near Boston
    Posts
    9,643
    Rep Power
    217378
    Still got the stockers on most of them.

    One went bad and I did the Taurus swap. I got the 'slightly wrong' version that had no lead - the connector was right on the motor, which actually worked out ok in my case. The original fan had done pretty much what yours did, started to seize up and melted the factory connector. I got the body side of the harness off a Taurus and soldered it onto the Jeep harness.

    Radiators are stockers too except for the 93. I think the replacement was radiatorbarn or whatever, from an ebay link someone had thrown up on one of the forums. That was years ago btw and it was still doing it's thing when I took the 93 off the road.

    Nothing interesting as far as the temps. Gauges are generally straight up in the normal range, none of them run noticably hot, or cool either for that matter

  4. #4
    Forum CONDUCTOR Man Z88Z's Avatar
    Join Date
    Jan 2009
    Location
    near Boston
    Posts
    9,643
    Rep Power
    217378
    Moving this thread to tech questions btw...

  5. #5
    Member NoTime's Avatar
    Join Date
    Jan 2009
    Location
    Sudbury, Ontario, Canada
    Posts
    2,248
    Rep Power
    150
    Does the Mark VIII fan have TWO speeds and if so are you running harness to the High or low fan wire........ There will be 3 wires,,, one being ground and the other two will be high and low. Do not hook these together.

    The harness you have,,, can you post a link to it so we can see what you are talking about.
    1998 ZJ 5.9 Platinum - 408 SC Sleeper ( 7.49 / 11.? )
    2012 RAM - Tow Vehicle
    2007 GC SRT8 Daily Driver
    2003 TJ Rubicon Inca Gold - Trail blaster
    1973 Trumph GT6 MK III
    20 Ft Enclosed Car Hauler

  6. #6
    Member
    Join Date
    Aug 2012
    Posts
    133
    Rep Power
    65
    3.8 taurus fan with fk-55 controller

    http://www.dccontrol.com/constant_temperature_controllers.htm

    i
    used a fuseable link, my fan spiked to 120 amps when the high kicks on and 40amps constant, fuses are impractical for big fans,

    but this controller PWM the voltage up, no amp spike, no anoying cycling of the fan

  7. #7
    Member NoTime's Avatar
    Join Date
    Jan 2009
    Location
    Sudbury, Ontario, Canada
    Posts
    2,248
    Rep Power
    150
    Yep, on above controller,,,, I spoke with Brian from DCC last week and I will be ordering.

    But first I wanted to see how the original op had things wired and what the harness looked like.
    1998 ZJ 5.9 Platinum - 408 SC Sleeper ( 7.49 / 11.? )
    2012 RAM - Tow Vehicle
    2007 GC SRT8 Daily Driver
    2003 TJ Rubicon Inca Gold - Trail blaster
    1973 Trumph GT6 MK III
    20 Ft Enclosed Car Hauler

  8. #8
    RallyJeep GO
    Join Date
    Jan 2010
    Location
    Rochester, NY
    Posts
    4,343
    Rep Power
    138
    Stock 5.9 e-fan (was replaced at some point in the past), ungodly expensive Griffin radiator. It should cool great once I figure out why I have crappy airflow through the rad at highway speeds (cools fine now except when towing above 50 mph).
    1998 ZJ 5.9 Limited - Deep Slate
    Mods: Big trans cooler, 231 swap, Indy MA-X heads prepped by IMM, Comp 20-744-9 cam, 1.7 HS roller rockers, 52mm TB, Airgap manifold, DT headers and full 3" exhaust, SCT tune homebrewed by me, Martin Saine valve body, B&M tranny pan, magic suspension made from unicorn tears, power steering cooler, lots of lighting mods

  9. #9
    Member
    Join Date
    Jan 2010
    Location
    Austria
    Posts
    105
    Rep Power
    96
    at the moment was the cooling system stock but I put following parts in it - when I've time for it

    180F thermostat
    Radiator
    http://www.radiators4less.com/node/detail/360000
    Fan-Control 200F on/ 185off
    http://www.summitracing.com/parts/HDA-3651/

    I think/hope these upgrades holds the temp down

  10. #10
    Member Paranign's Avatar
    Join Date
    Jan 2009
    Location
    Cabin On The Hill
    Posts
    430
    Rep Power
    111
    What fuse holder are you using, pic?
    What gauge wire to the efan?
    Sounds like the fan clutch is shot on the stock setup.
    94 ZJ Limited - 5.9, Edelbrock headers w/full 2.5" Flowmaster exhaust, Comp torque cam, EQ 1.92 heads, 3.5" lift, Bilstein, OME HD coils, Truetracs F/R, 31" Cooper STT, Galaxy CB, JKS Supernerfs, Mopar efan w/DC Controls box, 242 TC, built trans, 4.10

    95 ZJ Limited - 5.9, 2.5" Flowmaster exhaust, UC, 242 TC, Taurus efan, MX6, mostly stock

Similar Threads

  1. A/C and radiator cooling fan does not work...?
    By SLPRJP in forum Tech Questions
    Replies: 13
    Last Post: 08-04-2010, 04:53 PM
  2. Replies: 10
    Last Post: 07-08-2009, 09:52 AM
  3. Cooling
    By Endless in forum Tech Questions
    Replies: 5
    Last Post: 06-05-2009, 09:36 AM
  4. This kind of scares me
    By Ninergrad in forum Pictures and Videos
    Replies: 31
    Last Post: 03-17-2009, 08:30 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •