Results 1 to 6 of 6
  1. #1
    Member Cameleer's Avatar
    Join Date
    May 2012
    Location
    Ventura Ca
    Posts
    38
    Rep Power
    66

    ZJ 5.9 starts for a few seconds then shuts off

    I only had this Niner for a few months. Had s stereo installed about 2 weeks ago, no problems. Few days later had them hook up the steering wheel controls, the gas gauge didn't work when I left the shop. Drove right back to the shop, when I started my ZK back up the gas gauge worked. Then it worked on and off, next all the gauges, power windows, power locks and AC went out but would work sometimes.

    Today went to start it after sitting for a few days, none of that's working again and my ZJ would only run for a few seconds even when gassing it (Still sounds nice for the few seconds it runs).
    Went ahead and replaced the BCM today, still no gauges, power windows, power locks or AC.

    Maybe this BCM is also bad and I have a second problem now like the crankshaft position sensor.
    I tried disconnecting the battery and resetting the alarm. There are extra wires under the dash from previous owners, but I didn't see any problems with them.

    Any ideas to help fix this would be very much appreciated.

  2. #2
    Member Cameleer's Avatar
    Join Date
    May 2012
    Location
    Ventura Ca
    Posts
    38
    Rep Power
    66
    It started fine this morning and everything was working. Gave the radio a little push and the gauges stopped, another push and they started working. Slid the radio out to look at the wiring, when trying to slide it back in at about 1.5" from all the way in it felt way to hard so I did not force it. Right now the radio is sticking out part, will work on the problem when I have more time.

  3. #3
    RallyJeep GO
    Join Date
    Jan 2010
    Location
    Rochester, NY
    Posts
    4,343
    Rep Power
    137
    I wonder if the radio wiring is damaged and shorting the CCD bus or something?
    1998 ZJ 5.9 Limited - Deep Slate
    Mods: Big trans cooler, 231 swap, Indy MA-X heads prepped by IMM, Comp 20-744-9 cam, 1.7 HS roller rockers, 52mm TB, Airgap manifold, DT headers and full 3" exhaust, SCT tune homebrewed by me, Martin Saine valve body, B&M tranny pan, magic suspension made from unicorn tears, power steering cooler, lots of lighting mods

  4. #4
    Member Cameleer's Avatar
    Join Date
    May 2012
    Location
    Ventura Ca
    Posts
    38
    Rep Power
    66
    The new radio is a Kenwood KCD-X701, the CCD is not hooked to it.
    This radio was pushed in so hard against the wiring behind it, I'll bet it cut into the CCD wire.
    Right now the ZJ is in the shop getting the rear differential and front axles shifts worked on.
    When I get it back I will check out the CCD wires behind the radio.

  5. #5
    Member Cameleer's Avatar
    Join Date
    May 2012
    Location
    Ventura Ca
    Posts
    38
    Rep Power
    66
    Got my Niner back from the shop yesterday from having the rear diff rebuilt.
    Spent today working on the radio wiring redoing a lot of what the stereo shop did.
    Found the CCD twisted pair White/Black and Violet/Brown wires touching, taped them up and so far so good.
    Everything is Working now.

    wires1.jpgwires2.jpg

  6. #6
    RallyJeep GO
    Join Date
    Jan 2010
    Location
    Rochester, NY
    Posts
    4,343
    Rep Power
    137
    Perfect! Gotta love the simple fixes!
    1998 ZJ 5.9 Limited - Deep Slate
    Mods: Big trans cooler, 231 swap, Indy MA-X heads prepped by IMM, Comp 20-744-9 cam, 1.7 HS roller rockers, 52mm TB, Airgap manifold, DT headers and full 3" exhaust, SCT tune homebrewed by me, Martin Saine valve body, B&M tranny pan, magic suspension made from unicorn tears, power steering cooler, lots of lighting mods

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •