Page 13 of 13 FirstFirst ... 3 11 12 13
Results 301 to 303 of 303
  1. #301
    Member
    Join Date
    Sep 2013
    Posts
    564
    Rep Power
    4405
    Hmm, now the extension loaded all my last set of photos. Maybe I should post what it looks like installed? Part of me still says I should wait to just move the pics to another host.

  2. #302
    Member
    Join Date
    Sep 2013
    Posts
    564
    Rep Power
    4405
    Well, I did get the bumper installed before Christmas, with only a couple of minor issues. But on my club's Christmas tree run, the FlowKooler water pump started leaking. GRRR. It was intermittent though, so we could go a day without any leaks, and then it would dump a quart. I picked up and installed a new MOPAR pump from the dealership over New Year's weekend, but then the power steering pump started making a nasty racket. While trying to diagnose it, I ended up installing a new idler pulley and changing the A/C clutch pulley bearing in the parking lot of an Autozone while we were on a road trip. With that not solving the problem, I was glad we made it home, but three days of commuting later, it was PUKING fluid and the rattle was worse. I ordered up a new Lares pump/reservoir, along with the Cardone metal pulley, from RockAuto. It arrived Friday afternoon and I swapped it that night. Hopefully that's the last major maintenance issue I have to deal with for at least a couple months!

  3. #303
    Member
    Join Date
    Nov 2014
    Location
    Seattle
    Posts
    720
    Rep Power
    46
    How many miles did you get out of your FlowKooler? I've got one going on my new motor - hope it's not a mistake.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •